LES BSD Thread!

1234568

Comments

  • I think you can install the compiler by just doing:

    ftp -o - https://cdn.netbsd.org/pub/NetBSD/NetBSD-10.0/amd64/binary/sets/comp.tar.xz | progress -z tar xpf - -C /
    

    Alternatively, you could use sysinst to install additional packages (but need to be careful to not let sysinst overwrite any existing configuration)

    Thanked by (1)Not_Oles
  • Not_OlesNot_Oles Hosting ProviderContent Writer
    edited October 1

    @cmeerw said: I think a certctl rehash is missing (I need to add that to the image creation). PKG_PATH is already set in /etc/pkg_install.conf for that image

    @cmeerw Thanks for introducing me to certctl :) And /etc/pkg_install.conf :)

    linveo# man certctl
    man: Formatting manual page...
    CERTCTL(8)                  System Manager's Manual                 CERTCTL(8)
    
    NAME
         certctl - configure OpenSSL certificate trust anchors
    
    SYNOPSIS
         certctl [-nv] [-C config] [-c certsdir] [-u distrustdir] cmd [args...]
         certctl [options] list
         certctl [options] rehash
         certctl [options] trust cert
         certctl [options] untrust cert
         certctl [options] untrusted
    
    DESCRIPTION
         The certctl utility manages certificates used by OpenSSL-based
         applications as trust anchors for certificate validation in TLS or other
         purposes, for example by ftp(1) in HTTPS.  certctl allows configuring the
         set of certificates and persistently excluding individual certificates.
    
      [ . . . ]
    
    HISTORY
         certctl first appeared in NetBSD 10.0.  A utility of the same name
         previously appeared in FreeBSD 12.2.
    
    NetBSD 10.0                     August 16, 2023                    NetBSD 10.0
    linveo# cat  /etc/openssl/certs.conf
    netbsd-certctl 20230816
    
    #       $NetBSD: certs.conf,v 1.1.2.2 2023/09/04 17:33:27 martin Exp $
    #
    # Configuration file for certctl(8) to manage HTTPS root CA
    # certificates in /etc/openssl/certs.
    #
    
    path    /usr/share/certs/mozilla/server
    
    # For manual control over /etc/openssl/certs, e.g. if you want to
    # install a separate CA bundle from pkgsrc, uncomment the next line:
    #manual
    linveo# 
    
    linveo# cat /etc/pkg_install.conf
    PKG_PATH=https://cdn.netbsd.org/pub/pkgsrc/packages/NetBSD/amd64/10.0/All
    linveo# 
    

    @cmeerw said: so with a fresh install you can currently do:

    test# certctl rehash
    [ . . . ]
    test# pkg_add pkgin
    [ . . . ]
    test# pkgin upgrade

    linveo# certctl rehash
    linveo# pkg_add pkgin
    pkg_add: package `pkgin-23.8.1nb4' already recorded as installed
    linveo# pkgin upgrade
    pkg_summary.gz                                                  100% 6170KB 293.8KB/s   00:21    
    calculating dependencies...done.
    nothing to do.
    linveo# 
    

    Thanks again @cmeerw <3 Thanks to Linveo for the test VPSes! <3

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @cmeerw said:
    I think you can install the compiler by just doing:

    ftp -o - https://cdn.netbsd.org/pub/NetBSD/NetBSD-10.0/amd64/binary/sets/comp.tar.xz | progress -z tar xpf - -C /
    

    Alternatively, you could use sysinst to install additional packages (but need to be careful to not let sysinst overwrite any existing configuration)

    Showing the output of progress at a random momet during the download and extraction:

    linveo# pwd
    /root
    linveo# which gcc
    linveo# ftp -o - https://cdn.netbsd.org/pub/NetBSD/NetBSD-10.0/amd64/binary/sets/comp.tar.xz | progress -z tar xpf - -C /
     14975 KiB  623.57 KiB/s 
    

    Upon finishing:

    linveo# pwd
    /root
    linveo# which gcc
    linveo# ftp -o - https://cdn.netbsd.org/pub/NetBSD/NetBSD-10.0/amd64/binary/sets/comp.tar.xz | progress -z tar xpf - -C /
       561 MiB    1.10 MiB/s 
    linveo# which gcc
    /usr/bin/gcc
    linveo# 
    

    Next up might be to retry bootstrapping pkgsrc! :)

    Thanks again @cmeerw! <3 Thanks again Linveo! <3

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer
    linveo# cd /usr/pkgsrc/bootstrap
    linveo# export PKG_PATH=""
    linveo# ./bootstrap
    ===> bootstrap command: ./bootstrap 
    ===> bootstrap started: Tue Oct  1 01:49:46 UTC 2024
    "/usr/pkgsrc/bootstrap/work" already exists, please remove it or use --workdir
    linveo# rm -r work
    linveo# ./bootstrap 
    ===> bootstrap command: ./bootstrap 
    ===> bootstrap started: Tue Oct  1 01:50:47 UTC 2024
    Working directory is: /usr/pkgsrc/bootstrap/work
    ===> running: /usr/bin/sed -e 's|@DEFAULT_INSTALL_MODE@|'0755'|' /usr/pkgsrc/sysutils/install-sh/files/install-sh.in > /usr/pkgsrc/bootstrap/work/bin/install-sh
    ===> running: /bin/chmod +x /usr/pkgsrc/bootstrap/work/bin/install-sh
    ===> Creating default mk.conf in /usr/pkgsrc/bootstrap/work
    ===> running: /bin/sh /usr/pkgsrc/bootstrap/work/bin/install-sh -d -o root -g wheel /usr/pkgsrc/bootstrap/work/sbin
    ===> running: /bin/sh /usr/pkgsrc/bootstrap/work/bin/install-sh -d -o root -g wheel /usr/pkgsrc/bootstrap/work/share/mk
    ===> Bootstrapping mk-files
    ===> running: (cd /usr/pkgsrc/pkgtools/bootstrap-mk-files/files && env CP=/bin/cp  OPSYS=NetBSD MK_DST=/usr/pkgsrc/bootstrap/work/share/mk ROOT_GROUP=wheel ROOT_USER=root SED=/usr/bin/sed SYSCONFDIR=/usr/pkg/etc /bin/sh ./bootstrap.sh)
    ===> Bootstrapping bmake
    ===> running: /bin/sh /usr/pkgsrc/bootstrap/work/bin/install-sh -d -o root -g wheel /usr/pkgsrc/bootstrap/work/bmake
    ===> running: (cd /usr/pkgsrc/bootstrap/work/bmake && /bin/sh configure  --prefix=/usr/pkgsrc/bootstrap/work --with-default-sys-path=/usr/pkgsrc/bootstrap/work/share/mk --with-machine-arch=x86_64 )
    Using: filemon_ktrace.c
      [ . . .  ]
    
    You can now run
    
            sh ./make-bootstrap.sh
    
    to produce a fully functional bmake.
    
    ===> running: (cd /usr/pkgsrc/bootstrap/work/bmake && /bin/sh make-bootstrap.sh)
    gcc -c -g -O2 -I. -I/usr/pkgsrc/bootstrap/work/bmake -DHAVE_CONFIG_H -DUSE_EMALLOC -DMAKE_NATIVE -DUSE_META -DBMAKE_PATH_MAX=1024 -DMAKE_VERSION="20240909" -DMACHINE="amd64" -DMACHINE_ARCH="x86_64" -DMAKE_OS="" -D_PATH_DEFSYSPATH="/usr/pkgsrc/bootstrap/work/share/mk" -o main.o /usr/pkgsrc/bootstrap/work/bmake/main.c
      [ . . . ]
    ===> running: /bin/sh /usr/pkgsrc/bootstrap/work/bin/install-sh -c -o root -g wheel -m 755 /usr/pkgsrc/bootstrap/work/bmake/bmake /usr/pkgsrc/bootstrap/work/bin/bmake
      [ . . . ]
    ===> running: (cd /usr/pkgsrc/pkgtools/cwrappers && /usr/pkgsrc/bootstrap/work/bin/bmake  MAKE_JOBS=1 PKG_COMPRESSION=none PKGSRC_KEEP_BIN_PKGS=no MAKECONF=/usr/pkgsrc/bootstrap/work/mk.conf install)
    ERROR: This package has set PKG_FAIL_REASON:
    ERROR: Please unset PKG_PATH before doing pkgsrc work!
    *** Error code 1
    
    Stop.
    bmake: stopped making "install" in /usr/pkgsrc/pkgtools/cwrappers
    ===> exited with status 1
    aborted.
    linveo# 
    

    So, "unset PKG_PATH" is not the same as "export PKG_PATH=""". Apparently I need to have no PKG_PATH variable at all?

    But we said

    linveo# cat /etc/pkg_install.conf
    PKG_PATH=https://cdn.netbsd.org/pub/pkgsrc/packages/NetBSD/amd64/10.0/All
    linveo# 
    

    Next is to read up on "unset." :) Sounds like a shell built-in, so that all I need to do is run unset PKG_PATH.

    Hmm. Well, maybe I don't have to look too far.

    linveo# ps
      PID TTY   STAT    TIME COMMAND
    15318 pts/0 O+   0:00.00 ps 
    19420 pts/0 Ss   0:00.02 -sh 
     1315 ttyE0 Is+  0:00.00 /usr/libexec/getty Pc constty 
    linveo# 
    

    Yeah, I am using the sh shell, which I guess is the default.

    linveo# man sh
    
      [ . . . ]
    
         unset [-efvx] name ...
                If -v is specified, the specified variables are unset and
                unexported.  Readonly variables cannot be unset.  If -f is
                specified, the specified functions are undefined.  If -e is given,
                the specified variables are unexported, but otherwise unchanged,
                alternatively, if -x is given, the exported status of the variable
                will be retained, even after it is unset.
    
                If no flags are provided -v is assumed.  If -f is given with one
                of the other flags, then the named variables will be unset, or
                unexported, and functions of the same names will be undefined.
                The -e and -x flags both imply -v.  If -e is given, the -x flag is
                ignored.
    
                The exit status is 0, unless an attempt was made to unset a
                readonly variable, in which case the exit status is 1.  It is not
                an error to unset (or undefine) a variable (or function) that is
                not currently set (or defined.)
    
      [ . . . ]
    
    linveo# 
    

    Looks like maybe it's enough to unset PKG_PATH and to again remove /usr/pkgsrc/bootstrap/work. But maybe I should ditch PKG_PATH from .profile?

    linveo# grep PKG_PATH .profile
    #export PKG_PATH="https://cdn.NetBSD.org/pub/pkgsrc/packages/NetBSD/$(uname -p)/$(uname -r|cut -f '1 2' -d.|cut -f 1 -d_)/All"
    linveo# 
    

    Wait! That PKG_PATH line already is commented out!

    And there seems to be no PKG_PATH variable. . . .

    linveo# echo $PKG_PATH
    
    linveo#
    

    Why did ./bootstrap throw that error based on PKG_PATH?

    Now I'm confused! Haha! :)

    More tomorrow, since it's getting late here. . . .

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @Not_Oles said: More tomorrow, since it's getting late here. . . .

    It's even later than "getting late." But, anyway, one more try. And one more error. :)

    linveo# cd /usr/pkgsrc/bootstrap
    linveo# ls
    CVS                README.GNUkFreeBSD README.MidnightBSD README.OpenServer5 cleanup
    README             README.HPUX        README.Minix3      README.Solaris     work
    README.AIX         README.Haiku       README.MirBSD      README.UnixWare    
    README.Cygwin      README.IRIX        README.NetBSD      README.macOS
    README.DragonFly   README.Interix     README.OSF1        bootstrap
    README.FreeBSD     README.Linux       README.OpenBSD     testbootstrap
    linveo# rm -r work
    linveo# echo $PKG_PATH
    
    linveo# env | grep PKG_PATH
    linveo# ./bootstrap
    
      [ . . .  Lots of scrolling . . . ]
    
    => Automatic manual page handling
    => Generating post-install file lists
    => Checking file-check results for pkg_install-20240826
    => Creating binary package /usr/pkgsrc/bootstrap/work/wrk/pkgtools/pkg_install/work/.packages/pkg_install-20240826.tgz
    ===> Installing binary package of pkg_install-20240826
    pkg_add: A different version of pkg_install-20240826 is already installed: pkg_install-20240307
    pkg_add: 1 package addition failed
    *** Error code 1
    
    Stop.
    bmake[2]: stopped making "su-real-package-install" in /usr/pkgsrc/pkgtools/pkg_install
    *** Error code 1
    
    Stop.
    bmake[1]: stopped making "install" in /usr/pkgsrc/pkgtools/pkg_install
    *** Error code 1
    
    Stop.
    bmake: stopped making "install" in /usr/pkgsrc/pkgtools/pkg_install
    ===> exited with status 1
    aborted.
    linveo# 
    

    So I guess I have to remove pkg_install-20240307. :) Or maybe remove something of which contains pkg_install-20240307 as a part? :)

    More tomorrow. <3 Thanks BSD! <3 Thanks Linveo! <3

    I hope everyone gets the servers they want!

  • @Not_Oles said: Next up might be to retry bootstrapping pkgsrc!

    I don't think you need to do any bootstrapping on NetBSD, just cd to the package you want to build and type make there.

    NetBSD already contains the necessary tools for using pkgsrc; on other platforms you need to bootstrap pkgsrc to get the package management tools installed.

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @cmeerw said:

    I don't think you need to do any bootstrapping on NetBSD, just cd to the package you want to build and type make there.

    ROTFL!

    I really like that fine guys like @cmeerw catch my many mistakes! That's great! <3

    The language @cmeerw quoted appears in both the NetBSD packages collection documentation at https://www.netbsd.org/docs/software/packages.html and also on the pkgsrc.org home page.

    The language @cmeerw quoted does not seem to appear in either /use/pkgsrc/bootstrap/README or /use/pkgsrc/bootstrap/README.NetBSD.

    So, to clean up, maybe all I need to do is remove /usr/pkgsrc/bootstrap/work.

    Next up might be to build something with pkgsrc. Maybe Lynx or notqmail.

    Maybe move soon from NetBSD 10 to NetBSD-current. I probably need to add /src in a similar way to how the compiler set was added. Then update with CVS. Then maybe NetBSD-current will rebuild itself from /src. Amazing!

    Thanks *BSD! Thanks NetBSD! Thanks @cmeerw! Thanks Linveo! <3

    I hope everyone gets the servers they want!

  • @Not_Oles said: Maybe move soon from NetBSD 10 to NetBSD-current. I probably need to add /src in a similar way to how the compiler set was added. Then update with CVS. Then maybe NetBSD-current will rebuild itself from /src. Amazing!

    Unless you really want to rebuild everything from source, you can just use sysupgrade (from pkgsrc) and point it to the latest HEAD build.

    Thanked by (1)Not_Oles
  • Not_OlesNot_Oles Hosting ProviderContent Writer
    edited October 1

    @cmeerw said: Unless you really want to rebuild everything from source

    Thanks @cmeerw! <3 Not so much that I want to rebuild everything from source. It's mainly that I can rebuild everything from source. And I'm not sure that I can rebuild everything until I actually do rebuild everything.

    Once the rebuild completes successfully, it means that anything big or little can be changed. Not that I am capable of making the changes myself, but the NetBSD guys always were extremely friendly and extremely helpful and super fast to respond! I imagine that NetBSD culture still is the same. <3

    I hope everyone gets the servers they want!

  • I have created a new NetBSD 10.0 image with these changes:

    • certificates are now set up correctly out of the box (thanks @Not_Oles for pointing that out)
    • use "log" option on the root filesystem
    • pre-install "modules" and "rescue" packages
    • set savecore=NO in rc.conf and fetch_pkg_vulnerabilities="YES" in daily.conf

    @linveo could you update to the new image please? Hopefully, this should be fairly stable now.

    (Note: the image is AMD only - although I could use a patched kernel, I think it's better to stick with official kernels to avoid having the VM break when updating the kernel)

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @cmeerw said:
    I have created a new NetBSD 10.0 image with these changes:

    • certificates are now set up correctly out of the box (thanks @Not_Oles for pointing that out)
    • use "log" option on the root filesystem
    • pre-install "modules" and "rescue" packages
    • set savecore=NO in rc.conf and fetch_pkg_vulnerabilities="YES" in daily.conf

    @linveo could you update to the new image please? Hopefully, this should be fairly stable now.

    (Note: the image is AMD only - although I could use a patched kernel, I think it's better to stick with official kernels to avoid having the VM break when updating the kernel)

    Thanks @cmeerw! This is great because it permits Linux users everywhere to have easy access to NetBSD. Plus also, NetBSD fans easily can run NetBSD in lots of inexpensive cloud environments, as long as providers like Linveo are kind enough to add the image.

    May I please ask which NetBSD install sets are included in your new image?

    Would it make sense to provide a NetBSD-current image with all sets included? :) :) :)

    To what extent could your new image be used generally on Linux with Qemu? I guess the image would run on any architecture which supports Qemu emulation of AMD64?

    Thanks again! Best wishes!

    I hope everyone gets the servers they want!

  • @Not_Oles said: May I please ask which NetBSD install sets are included in your new image?

    I am installing "base etc kern-GENERIC man modules rescue" now.

    @Not_Oles said: Would it make sense to provide a NetBSD-current image with all sets included?

    I don't think it would make a lot of sense as the image would be quite large and as NetBSD-current changes daily, the image would need to change very frequently as well. I think it makes a lot more sense to use 10.0 as a starting point and then update to current. sysupgrade is a very nice tool that makes updating to current (and keeping up to date) very easy.

    Essentially you would

    • install sysupgrade (pkg_add sysupgrade)
    • set RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/$(uname -m)" in /usr/pkg/etc/sysupgrade.conf
    • touch set.* files in /etc/mtree for additional package you want to install during the upgrade
    • sysupgrade auto

    @Not_Oles said: To what extent could your new image be used generally on Linux with Qemu? I guess the image would run on any architecture which supports Qemu emulation of AMD64?

    The main thing here is how to get network interfaces and SSH keys configured in the VM. VirtFusion seems to do that by making a small CD filesystem available that contains yaml files with the configuration data. I am looking for that filesystem, reading the yaml files and configuring the NetBSD system. I am actually not using the full cloud-init package to do that (as that would pull in way too many dependencies for my taste), but just using a small lua script for that.

    On your linveo VM you might see a sd0 drive (although that drive seems to disappear some time after the VM has been set up).

    Thanked by (1)Not_Oles
  • Not_OlesNot_Oles Hosting ProviderContent Writer
    edited October 5

    @cmeerw said:

    sysupgrade is a very nice tool that makes updating to current (and keeping up to date) very easy.

    Essentially you would

    install sysupgrade (pkg_add sysupgrade)
    set RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/$(uname -m)" in /usr/pkg/etc/sysupgrade.conf
    touch set.* files in /etc/mtree for additional package you want to install during the upgrade
    sysupgrade auto

    Suppose I try following @cmeerw's kind instructions for running sysupgrade on my presently installed VM -- in other words, not yet the newly updated @cmeerw image which he just mentioned above.

    • Start by installing sysupgrade:
    linveo# date
    Fri Oct  4 19:23:32 UTC 2024
    linveo# pkg_add sysupgrade
    sysupgrade-1.5nb10: copying /usr/pkg/share/examples/sysupgrade/default.conf to /usr/pkg/etc/sysupgrade.conf
    linveo# 
    
    • Next, set RELEASEDIR in /usr/pkg/etc/sysupgrade.conf:
    linveo# date
    Fri Oct  4 23:55:56 UTC 2024
    linveo# cd /usr/pkg/etc
    linveo# ls
    pkgin           sysupgrade.conf
    linveo# cat -n sysupgrade.conf 
         1  # $NetBSD: default.conf,v 1.2 2012/10/11 00:16:46 jmmv Exp $
         2
         3  # Configuration of automatic system upgrades by sysupgrade(8).
         4  #
         5  # See sysupgrade.conf(5) for details on the syntax of this file and the
         6  # meaning of the configuration variables.  Note that not all the supported
         7  # configuration variables are listed in this sample configuration file.
         8
         9  # Path to the release files (local path or remote URL).
        10  #RELEASEDIR="ssh://[email protected]/home/sysbuild/release/$(uname -m)"
        11  #RELEASEDIR="/home/sysbuild/release/$(uname -m)"
        12  #RELEASEDIR="https://cdn.NetBSD.org/pub/NetBSD/NetBSD-9.1/$(uname -m)"
        13  # Upgrade to the latest snapshot of the current branch
        14  #RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/$(uname -m)"
        15  # Upgrade to the latest snapshot of a stable branch
        16  RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-9/latest/$(uname -m)"
        17
        18  # Name of the kernel to be installed.
        19  KERNEL=AUTO  # Guess from /netbsd (requires config(1)).
        20
        21  # Whitespace-separated list of sets to install.
        22  SETS=AUTO  # Guess from /etc/mtree/set.* files.
        23
        24  # Whitespace-separated list of postinstall(8) checks to automatically fix.
        25  POSTINSTALL_AUTOFIX="obsolete"
        26
        27  # Whether to run etcupdate or not as part of an upgrade.
        28  #
        29  # Running etcupdate is the only interactive step in the upgrade process, so
        30  # setting this variable to 'no' effectively makes upgrades unattended.  You
        31  # can later run etcupdate at a later step by hand.
        32  #ETCUPDATE=no
        33
        34  # Whether to delete the downloaded files after an upgrade or not.
        35  #
        36  # If you set ETCUPDATE=no, you will most likely want to disable
        37  # auto-cleaning as well.  The reason for this is that, if you want to later
        38  # do "sysupgrade etcupdate" using the same etc.tgz file downloaded during
        39  # the upgrade, you will need the same etc.tgz file to be present.
        40  #AUTOCLEAN=no
        41
        42  # Archive file extension of the sets. For now it can be either 'tgz' or
        43  # 'tar.xz'.
        44  #ARCHIVE_EXTENSION=tar.xz
    linveo# ed sysupgrade.conf 
    1920
    16
    RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-9/latest/$(uname -m)"
    s/^/# /p
    # RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-9/latest/$(uname -m)"
    a
    RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/$(uname -m)"
    .
    w
    2001
    16,17p
    # RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-9/latest/$(uname -m)"
    RELEASEDIR="https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/$(uname -m)"
    q
    linveo# 
    
    • Next, "touch set.* files in /etc/mtree" for additional sets.

    What I already have in etc/mtree might be missing at least set.misc, set.modules, set.rescue, and set.text. Plus it also is missing the X sets, but I am okay with skipping X for the time being. Maybe I am okay with skipping modules, too.

    linveo# cd /etc/mtree
    linveo# ls -l
    total 4896
    -r--r--r--  1 root  wheel    68983 Mar 28  2024 NetBSD.dist
    -r--r--r--  1 root  wheel   880419 Mar 28  2024 set.base
    -r--r--r--  1 root  wheel  3048246 Mar 28  2024 set.comp
    -r--r--r--  1 root  wheel    48302 Mar 28  2024 set.etc
    -r--r--r--  1 root  wheel   914350 Mar 28  2024 set.man
    -r--r--r--  1 root  wheel    20222 Mar 28  2024 special
    linveo# 
    

    The touched files do not have any content, unlike all the other files in /etc/mtree.

    linveo# date
    Sat Oct  5 00:06:52 UTC 2024
    linveo# cd /etc/mtree
    linveo# ls -l
    total 4896
    -r--r--r--  1 root  wheel    68983 Mar 28  2024 NetBSD.dist
    -r--r--r--  1 root  wheel   880419 Mar 28  2024 set.base
    -r--r--r--  1 root  wheel  3048246 Mar 28  2024 set.comp
    -r--r--r--  1 root  wheel    48302 Mar 28  2024 set.etc
    -r--r--r--  1 root  wheel   914350 Mar 28  2024 set.man
    -r--r--r--  1 root  wheel    20222 Mar 28  2024 special
    linveo# touch set.misc set.rescue set.text
    linveo# ls -l
    total 4896
    -r--r--r--  1 root  wheel    68983 Mar 28  2024 NetBSD.dist
    -r--r--r--  1 root  wheel   880419 Mar 28  2024 set.base
    -r--r--r--  1 root  wheel  3048246 Mar 28  2024 set.comp
    -r--r--r--  1 root  wheel    48302 Mar 28  2024 set.etc
    -r--r--r--  1 root  wheel   914350 Mar 28  2024 set.man
    -rw-r--r--  1 root  wheel        0 Oct  5 00:07 set.misc
    -rw-r--r--  1 root  wheel        0 Oct  5 00:07 set.rescue
    -rw-r--r--  1 root  wheel        0 Oct  5 00:07 set.text
    -r--r--r--  1 root  wheel    20222 Mar 28  2024 special
    linveo# 
    

    Okay, now let's try running sysupgrade auto -- I will post about what happens. :)

    --------

    Meanwhile, here are a few interesting snippets from my homework skimming:

    linveo# man sysupgrade
    man: Formatting manual page...
    SYSUPGRADE(8)               System Manager's Manual              SYSUPGRADE(8)
    
    NAME
         sysupgrade - upgrades a NetBSD system to a newer version
    
    SYNOPSIS
         common_flags ::= [-c config_name] [-d destdir] [-o variable=value]
    
    DESCRIPTION
         sysupgrade is a utility that automates the process of upgrading a
         possibly-running NetBSD system to a newer release.
    
         sysupgrade works by first fetching the release sets from a remote site or
         from a local directory, then by upgrading the system using such release
         sets and finally by taking care of bringing the system configuration up
         to date.  In other words, sysupgrade does nothing special on its own: it
         is just a utility that automates a highly manual process and relies on
         other tools within the system to perform its job.
    
         sysupgrade has a subcommand-based interface: every command performs a
         single step of the upgrade procedure, and the `auto' command orchestrates
         a complete upgrade by invoking the rest of the commands in a specific
         order.  There are a set of options that apply to all commands (those
         stated before the command name), and every particular command may accept
         its own options and arguments as shown in the synopsis.
    
         The behavior of sysupgrade is defined by a configuration file that
         specifies how to apply an update to the system (see sysupgrade.conf(5)).
         For example, the configuration states which distribution sets ought to be
         installed, where they need to be downloaded from, and whether the system
         configuration files should be upgraded.
    
      [ . . . ]
    
    EXAMPLES AND TROUBLESHOOTING
         The most common way of executing sysupgrade is by using the `auto'
         command and relying in the default configuration file:
    
               $ sysupgrade auto
    
      [ . . . ]
    
    SEE ALSO
         sysbuild(1), sysupgrade.conf(5), etcupdate(8), postinstall(8)
    
    AUTHORS
         The sysupgrade utility was developed by Julio Merino <[email protected]>.
    
      [ . . . ]
    
    linveo# man mtree
    man: Formatting manual page...
    MTREE(8)                    System Manager's Manual                   MTREE(8)
    
    NAME
         mtree - map a directory hierarchy
    
    SYNOPSIS
         mtree [-bCcDdejLlMnPqrStUuWx] [-i | -m] [-E tags] [-F flavor] [-f spec]
               [-I tags] [-K keywords] [-k keywords] [-N dbdir] [-O onlyfile]
               [-p path] [-R keywords] [-s seed] [-X exclude-file]
    
    DESCRIPTION
         The mtree utility compares a file hierarchy against a specification,
         creates a specification for a file hierarchy, or modifies a
         specification.
    
      [ . . . ]
    
    HISTORY
         The mtree utility appeared in 4.3BSD-Reno.  [ . . . ]
    
     [ . . . ]
    
    linveo# 
    

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    Here is the output from running sysupgrade auto.

    Probably I should run the fix given at the end for the failed postinstall checks.

    What about the lines that say

    "[1] Bad system call (core dumped) /usr/sbin/etcupdate -a -l ${sflags}"

    and

    "[1] Bad system call (core dumped) ${HOST_SH} "${MAKEDEV_DIR}/MAKEDEV" -s pty0 2>... |"?

    linveo# date
    Sat Oct  5 00:24:12 UTC 2024
    linveo# sysupgrade auto
    sysupgrade: I: Starting auto-update with stages: fetch modules kernel sets etcupdate postinstall clean
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/base.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42:400::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/base.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/base.tar.xz
    Trying [2a04:4e42::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/base.tar.xz
    100% |*****************************************************| 40680 KiB  174.90 KiB/s    00:00 ETA
    41657052 bytes retrieved in 03:52 (174.90 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/comp.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42:600::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/comp.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/comp.tar.xz
    Trying [2a04:4e42:400::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/comp.tar.xz
    100% |*****************************************************| 82243 KiB  169.25 KiB/s    00:00 ETA
    84217696 bytes retrieved in 08:05 (169.25 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/etc.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/etc.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/etc.tar.xz
    Trying [2a04:4e42::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/etc.tar.xz
    100% |*****************************************************|   497 KiB  168.08 KiB/s    00:00 ETA
    509504 bytes retrieved in 00:02 (168.08 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/man.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42:400::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/man.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/man.tar.xz
    Trying [2a04:4e42:200::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/man.tar.xz
    100% |*****************************************************|  5557 KiB  172.83 KiB/s    00:00 ETA
    5691280 bytes retrieved in 00:32 (172.83 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/misc.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42:400::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/misc.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/misc.tar.xz
    Trying [2a04:4e42:200::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/misc.tar.xz
    100% |*****************************************************|  4058 KiB  169.19 KiB/s    00:00 ETA
    4156132 bytes retrieved in 00:23 (169.19 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/rescue.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42:600::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/rescue.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/rescue.tar.xz
    Trying [2a04:4e42:600::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/rescue.tar.xz
    100% |*****************************************************|  3437 KiB  168.19 KiB/s    00:00 ETA
    3519676 bytes retrieved in 00:20 (168.19 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/text.tar.xz into /var/cache/sysupgrade
    Trying [2a04:4e42::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/sets/text.tar.xz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/text.tar.xz
    Trying [2a04:4e42:400::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/sets/text.tar.xz
    100% |*****************************************************|  1893 KiB  170.57 KiB/s    00:00 ETA
    1938608 bytes retrieved in 00:11 (170.57 KiB/s)
    sysupgrade: I: Downloading https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/kernel/netbsd-GENERIC.gz into /var/cache/sysupgrade
    Trying [2a04:4e42:400::262]:443 ...
    Requesting https://nycdn.netbsd.org/pub/NetBSD-daily/HEAD/latest/amd64/binary/kernel/netbsd-GENERIC.gz
    Redirected to /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/kernel/netbsd-GENERIC.gz
    Trying [2a04:4e42:200::262]:443 ...
    Requesting /pub/NetBSD-daily/HEAD/202410030430Z/amd64/binary/kernel/netbsd-GENERIC.gz
    100% |*****************************************************| 10880 KiB  174.65 KiB/s    00:00 ETA
    11141441 bytes retrieved in 01:02 (174.65 KiB/s)
    sysupgrade: I: Skipping modules installation (modules not in SETS)
    sysupgrade: I: Upgrading kernel using GENERIC in /
    sysupgrade: I: Backing up 'netbsd' kernel as 'onetbsd'
    sysupgrade: I: Upgrading base system
    sysupgrade: I: Extracting base into /
    100% |*****************************************************| 40680 KiB  491.59 KiB/s  - stalled -
    sysupgrade: I: Extracting comp into /
    100% |*****************************************************| 82243 KiB  369.57 KiB/s    00:00 ETA
    sysupgrade: I: Extracting man into /
    100% |*****************************************************|  5557 KiB  117.96 KiB/s    00:00 ETA
    sysupgrade: I: Extracting misc into /
    100% |*****************************************************|  4058 KiB  664.97 KiB/s    00:00 ETA
    sysupgrade: I: Extracting rescue into /
    100% |*****************************************************|  3437 KiB    1.58 MiB/s    00:00 ETA
    sysupgrade: I: Extracting text into /
    100% |*****************************************************|  1893 KiB  328.65 KiB/s    00:00 ETA
    sysupgrade: I: Upgrading /etc interactively
    *** Creating /tmp/temproot
    *** Populating /tmp/temproot from /var/cache/sysupgrade/etc.tar.xz
    *** Checking for new directories
    [1]   Bad system call (core dumped) /usr/sbin/etcupdate -a -l ${sflags}
    sysupgrade: I: Performing postinstall checks
    Note: Creating temporary directory /tmp/_postinstall.19628.0/etc.tgz
    Note: Extracting files from /var/cache/sysupgrade/etc.tar.xz
    Source directory: /tmp/_postinstall.19628.0/etc.tgz
     (extracted from: /var/cache/sysupgrade/etc.tar.xz)
    Target directory: /
    obsolete fix:
            Removed obsolete file /usr/share/man/man5/openssl_config.5
            Removed obsolete file /usr/share/man/man4/i386/viac7temp.4
            Removed obsolete file /usr/share/man/man3/openssl_evp.3
            Removed obsolete file /usr/share/man/man3/openssl_bio.3
            Removed obsolete file /usr/share/man/man1/xstr.1
            Removed obsolete file /usr/share/man/man1/openssl_x509.1
            Removed obsolete file /usr/share/man/man1/openssl_version.1
            Removed obsolete file /usr/share/man/man1/openssl_verify.1
            Removed obsolete file /usr/share/man/man1/openssl_tsget.1
            Removed obsolete file /usr/share/man/man1/openssl_ts.1
            Removed obsolete file /usr/share/man/man1/openssl_storeutl.1
            Removed obsolete file /usr/share/man/man1/openssl_srp.1
            Removed obsolete file /usr/share/man/man1/openssl_spkac.1
            Removed obsolete file /usr/share/man/man1/openssl_speed.1
            Removed obsolete file /usr/share/man/man1/openssl_smime.1
            Removed obsolete file /usr/share/man/man1/openssl_sess_id.1
            Removed obsolete file /usr/share/man/man1/openssl_s_time.1
            Removed obsolete file /usr/share/man/man1/openssl_s_server.1
            Removed obsolete file /usr/share/man/man1/openssl_s_client.1
            Removed obsolete file /usr/share/man/man1/openssl_rsautl.1
            Removed obsolete file /usr/share/man/man1/openssl_rsa.1
            Removed obsolete file /usr/share/man/man1/openssl_req.1
            Removed obsolete file /usr/share/man/man1/openssl_rehash.1
            Removed obsolete file /usr/share/man/man1/openssl_rand.1
            Removed obsolete file /usr/share/man/man1/openssl_prime.1
            Removed obsolete file /usr/share/man/man1/openssl_pkeyutl.1
            Removed obsolete file /usr/share/man/man1/openssl_pkeyparam.1
            Removed obsolete file /usr/share/man/man1/openssl_pkey.1
            Removed obsolete file /usr/share/man/man1/openssl_pkcs8.1
            Removed obsolete file /usr/share/man/man1/openssl_pkcs7.1
            Removed obsolete file /usr/share/man/man1/openssl_pkcs12.1
            Removed obsolete file /usr/share/man/man1/openssl_passwd.1
            Removed obsolete file /usr/share/man/man1/openssl_ocsp.1
            Removed obsolete file /usr/share/man/man1/openssl_nseq.1
            Removed obsolete file /usr/share/man/man1/openssl_list.1
            Removed obsolete file /usr/share/man/man1/openssl_genrsa.1
            Removed obsolete file /usr/share/man/man1/openssl_genpkey.1
            Removed obsolete file /usr/share/man/man1/openssl_gendsa.1
            Removed obsolete file /usr/share/man/man1/openssl_errstr.1
            Removed obsolete file /usr/share/man/man1/openssl_engine.1
            Removed obsolete file /usr/share/man/man1/openssl_enc.1
            Removed obsolete file /usr/share/man/man1/openssl_ecparam.1
            Removed obsolete file /usr/share/man/man1/openssl_ec.1
            Removed obsolete file /usr/share/man/man1/openssl_dsaparam.1
            Removed obsolete file /usr/share/man/man1/openssl_dsa.1
            Removed obsolete file /usr/share/man/man1/openssl_dhparam.1
            Removed obsolete file /usr/share/man/man1/openssl_dgst.1
            Removed obsolete file /usr/share/man/man1/openssl_crl2pkcs7.1
            Removed obsolete file /usr/share/man/man1/openssl_crl.1
            Removed obsolete file /usr/share/man/man1/openssl_cms.1
            Removed obsolete file /usr/share/man/man1/openssl_ciphers.1
            Removed obsolete file /usr/share/man/man1/openssl_ca.1
            Removed obsolete file /usr/share/man/man1/openssl_asn1parse.1
            Removed obsolete file /usr/share/man/man1/openssl_CA.pl.1
            Removed obsolete file /usr/share/man/man1/mkstr.1
            Removed obsolete file /usr/share/man/html5/openssl_config.html
            Removed obsolete file /usr/share/man/html3/openssl_evp.html
            Removed obsolete file /usr/share/man/html3/openssl_bio.html
            Removed obsolete file /usr/share/man/html1/xstr.html
            Removed obsolete file /usr/share/man/html1/openssl_storeutl.html
            Removed obsolete file /usr/share/man/html1/openssl_srp.html
            Removed obsolete file /usr/share/man/html1/openssl_rehash.html
            Removed obsolete file /usr/share/man/html1/openssl_prime.html
            Removed obsolete file /usr/share/man/html1/openssl_ocsp.html
            Removed obsolete file /usr/share/man/html1/openssl_list.html
            Removed obsolete file /usr/share/man/html1/openssl_engine.html
            Removed obsolete file /usr/share/man/html1/mkstr.html
            Removed obsolete link /usr/share/certs/mozilla/server/GLOBALTRUST_2020.pem
            Removed obsolete link /usr/share/certs/mozilla/email/certSIGN_ROOT_CA.pem
            Removed obsolete link /usr/share/certs/mozilla/email/GLOBALTRUST_2020.pem
            Removed obsolete link /usr/share/certs/mozilla/email/ACCVRAIZ1.pem
            Removed obsolete file /usr/libexec/named/filter-aaaa.so
            Removed obsolete directory /usr/libexec/named
            Removed obsolete directory /usr/include/gcc-9/sanitizer
            Removed obsolete directory /usr/include/gcc-9
            Removed obsolete file /usr/include/gcc-10/xtestintrin.h
            Removed obsolete file /usr/include/gcc-10/xsavesintrin.h
            Removed obsolete file /usr/include/gcc-10/xsaveoptintrin.h
            Removed obsolete file /usr/include/gcc-10/xsaveintrin.h
            Removed obsolete file /usr/include/gcc-10/xsavecintrin.h
            Removed obsolete file /usr/include/gcc-10/xopintrin.h
            Removed obsolete file /usr/include/gcc-10/xmmintrin.h
            Removed obsolete file /usr/include/gcc-10/x86intrin.h
            Removed obsolete file /usr/include/gcc-10/wmmintrin.h
            Removed obsolete file /usr/include/gcc-10/wbnoinvdintrin.h
            Removed obsolete file /usr/include/gcc-10/waitpkgintrin.h
            Removed obsolete file /usr/include/gcc-10/vpclmulqdqintrin.h
            Removed obsolete file /usr/include/gcc-10/vaesintrin.h
            Removed obsolete file /usr/include/gcc-10/tmmintrin.h
            Removed obsolete file /usr/include/gcc-10/tgmath.h
            Removed obsolete file /usr/include/gcc-10/tbmintrin.h
            Removed obsolete file /usr/include/gcc-10/stdatomic.h
            Removed obsolete file /usr/include/gcc-10/smmintrin.h
            Removed obsolete file /usr/include/gcc-10/shaintrin.h
            Removed obsolete file /usr/include/gcc-10/sgxintrin.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/tsan_interface_atomic.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/tsan_interface.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/netbsd_syscall_hooks.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/lsan_interface.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/common_interface_defs.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/asan_interface.h
            Removed obsolete file /usr/include/gcc-10/sanitizer/allocator_interface.h
            Removed obsolete file /usr/include/gcc-10/rtmintrin.h
            Removed obsolete file /usr/include/gcc-10/rdseedintrin.h
            Removed obsolete file /usr/include/gcc-10/prfchwintrin.h
            Removed obsolete file /usr/include/gcc-10/popcntintrin.h
            Removed obsolete file /usr/include/gcc-10/pmmintrin.h
            Removed obsolete file /usr/include/gcc-10/pkuintrin.h
            Removed obsolete file /usr/include/gcc-10/pconfigintrin.h
            Removed obsolete file /usr/include/gcc-10/openacc.h
            Removed obsolete file /usr/include/gcc-10/omp.h
            Removed obsolete file /usr/include/gcc-10/nmmintrin.h
            Removed obsolete file /usr/include/gcc-10/mwaitxintrin.h
            Removed obsolete file /usr/include/gcc-10/movdirintrin.h
            Removed obsolete file /usr/include/gcc-10/mmintrin.h
            Removed obsolete file /usr/include/gcc-10/mm_malloc.h
            Removed obsolete file /usr/include/gcc-10/mm3dnow.h
            Removed obsolete file /usr/include/gcc-10/lzcntintrin.h
            Removed obsolete file /usr/include/gcc-10/lwpintrin.h
            Removed obsolete file /usr/include/gcc-10/immintrin.h
            Removed obsolete file /usr/include/gcc-10/ia32intrin.h
            Removed obsolete file /usr/include/gcc-10/gfniintrin.h
            Removed obsolete file /usr/include/gcc-10/fxsrintrin.h
            Removed obsolete file /usr/include/gcc-10/fmaintrin.h
            Removed obsolete file /usr/include/gcc-10/fma4intrin.h
            Removed obsolete file /usr/include/gcc-10/f16cintrin.h
            Removed obsolete file /usr/include/gcc-10/enqcmdintrin.h
            Removed obsolete file /usr/include/gcc-10/emmintrin.h
            Removed obsolete file /usr/include/gcc-10/cross-stdarg.h
            Removed obsolete file /usr/include/gcc-10/cpuid.h
            Removed obsolete file /usr/include/gcc-10/clzerointrin.h
            Removed obsolete file /usr/include/gcc-10/clwbintrin.h
            Removed obsolete file /usr/include/gcc-10/clflushoptintrin.h
            Removed obsolete file /usr/include/gcc-10/cldemoteintrin.h
            Removed obsolete file /usr/include/gcc-10/cetintrin.h
            Removed obsolete file /usr/include/gcc-10/cet.h
            Removed obsolete file /usr/include/gcc-10/bmmintrin.h
            Removed obsolete file /usr/include/gcc-10/bmiintrin.h
            Removed obsolete file /usr/include/gcc-10/bmi2intrin.h
            Removed obsolete file /usr/include/gcc-10/avxintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vpopcntdqvlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vpopcntdqintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vp2intersectvlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vp2intersectintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vnnivlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vnniintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vldqintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vlbwintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vbmivlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vbmiintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vbmi2vlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512vbmi2intrin.h
            Removed obsolete file /usr/include/gcc-10/avx512pfintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512ifmavlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512ifmaintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512fintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512erintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512dqintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512cdintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512bwintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512bitalgintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512bf16vlintrin.h
            Removed obsolete file /usr/include/gcc-10/avx512bf16intrin.h
            Removed obsolete file /usr/include/gcc-10/avx5124vnniwintrin.h
            Removed obsolete file /usr/include/gcc-10/avx5124fmapsintrin.h
            Removed obsolete file /usr/include/gcc-10/avx2intrin.h
            Removed obsolete file /usr/include/gcc-10/ammintrin.h
            Removed obsolete file /usr/include/gcc-10/adxintrin.h
            Removed obsolete file /usr/include/g++/debug/array
            Removed obsolete file /usr/include/g++/bits/range_cmp.h
            Removed obsolete file /usr/bin/xstr
            Removed obsolete file /usr/bin/mkstr
            Removed obsolete file /lib/libblocklist.so.0.0
            Removed obsolete file /lib/libc.so.12.220
            Removed obsolete file /lib/libm.so.0.13
            Removed obsolete file /usr/lib/libarchive.so.5.0
            Removed obsolete link /usr/lib/libblocklist.so.0.0
            Removed obsolete file /usr/lib/libbsdmalloc.so.0.0
            Removed obsolete link /usr/lib/libc.so.12.220
            Removed obsolete file /usr/lib/libgomp.so.2.1
            Removed obsolete link /usr/lib/libm.so.0.13
            Removed obsolete file /usr/lib/libsqlite3.so.1.4
            Removed obsolete file /usr/lib/libstdc++.so.9.0
    postinstall fixes passed: obsolete
    postinstall fixes failed:
    Note: Creating temporary directory /tmp/_postinstall.26026.0/etc.tgz
    Note: Extracting files from /var/cache/sysupgrade/etc.tar.xz
    Source directory: /tmp/_postinstall.26026.0/etc.tgz
     (extracted from: /var/cache/sysupgrade/etc.tar.xz)
    Target directory: /
    atf check:
            (Checking for NetBSD.conf from /tmp/_postinstall.26026.0/etc.tgz/etc/atf instead of /tmp/_postinstall.26026.0/etc.tgz/external/bsd/atf/etc/atf)
            (Checking for atf-run.hooks from /tmp/_postinstall.26026.0/etc.tgz/etc/atf instead of /tmp/_postinstall.26026.0/etc.tgz/external/bsd/atf/dist/tools/sample)
    autofsconfig check:
    blocklist check:
    bluetooth check:
    catpages check:
    ddbonpanic check:
    defaults check:
            (Checking for pf.boot.conf from /tmp/_postinstall.26026.0/etc.tgz/etc/defaults instead of /tmp/_postinstall.26026.0/etc.tgz/usr.sbin/pf/etc/defaults)
            /tmp/_postinstall.26026.0/etc.tgz/etc/defaults/npf.boot.conf != /etc/defaults/npf.boot.conf
            /tmp/_postinstall.26026.0/etc.tgz/etc/defaults/rc.conf != /etc/defaults/rc.conf
    dhcpcd check:
            (Checking for dhcpcd.conf from /tmp/_postinstall.26026.0/etc.tgz/etc instead of /tmp/_postinstall.26026.0/etc.tgz/external/bsd/dhcpcd/dist/src)
    dhcpcdrundir check:
    envsys check:
    fontconfig check:
            /tmp/_postinstall.26026.0/etc.tgz/etc/fonts/conf.avail is not a directory; skipping check
    gid check:
    gpio check:
    hosts check:
    iscsi check:
    makedev check:
            (Checking for MAKEDEV from /tmp/_postinstall.26026.0/etc.tgz/dev instead of /tmp/_postinstall.26026.0)
            /tmp/_postinstall.26026.0/etc.tgz/dev/MAKEDEV != /dev/MAKEDEV
            (Checking for MAKEDEV.local from /tmp/_postinstall.26026.0/etc.tgz/dev instead of /tmp/_postinstall.26026.0/etc.tgz/etc)
    manconf check:
    motd check:
    mtree check:
            /tmp/_postinstall.26026.0/etc.tgz/etc/mtree/special != /etc/mtree/special
            /tmp/_postinstall.26026.0/etc.tgz/etc/mtree/NetBSD.dist != /etc/mtree/NetBSD.dist
    named check:
            /tmp/_postinstall.26026.0/etc.tgz/etc/namedb/root.cache != /etc/namedb/root.cache
    opensslcertsconf check:
    opensslcertsrehash check:
            /etc/openssl/certs needs rehash
    pam check:
    periodic check:
            /tmp/_postinstall.26026.0/etc.tgz/etc/security != /etc/security
    pf check:
            (Checking for pf.os from /tmp/_postinstall.26026.0/etc.tgz/etc instead of /tmp/_postinstall.26026.0/etc.tgz/dist/pf/etc)
    ptyfsoldnodes check:
    [1]   Bad system call (core dumped) ${HOST_SH} "${MAKEDEV_DIR}/MAKEDEV" -s pty0 2>... |
          Done                    ${AWK} "\
                BEGIN { before_re = \".*device=...
            Cannot find device major numbers for pty master and slave
    pwd_mkdb check:
    rc check:
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/bluetooth != /etc/rc.d/bluetooth
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/certctl_init != /etc/rc.d/certctl_init
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/ip6addrctl != /etc/rc.d/ip6addrctl
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/ipfs != /etc/rc.d/ipfs
            /etc/rc.d/iscsid_volumes does not exist
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/named != /etc/rc.d/named
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/npf != /etc/rc.d/npf
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/postfix != /etc/rc.d/postfix
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/resize_root != /etc/rc.d/resize_root
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/securelevel != /etc/rc.d/securelevel
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/sshd != /etc/rc.d/sshd
            /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d/sysdb != /etc/rc.d/sysdb
            (Checking for blocklistd from /tmp/_postinstall.26026.0/etc.tgz/etc/rc.d instead of /tmp/_postinstall.26026.0/etc.tgz/external/bsd/blocklist/etc/rc.d)
    ssh check:
            (Checking for moduli from /tmp/_postinstall.26026.0/etc.tgz/etc instead of /tmp/_postinstall.26026.0/etc.tgz/crypto/external/bsd/openssh/dist)
    tcpdumpchroot check:
    uid check:
    varrwho check:
    varshm check:
    wscons check:
    x11 check:
    xkb check:
    obsolete check:
    postinstall checks passed: atf autofsconfig blocklist bluetooth catpages ddbonpanic dhcpcd dhcpcdrundir envsys fontconfig gid gpio hosts iscsi manconf motd named opensslcertsconf pam pf pwd_mkdb ssh tcpdumpchroot uid varrwho varshm wscons x11 xkb obsolete
    postinstall checks failed: defaults makedev mtree opensslcertsrehash periodic ptyfsoldnodes rc
    To fix, run:
        sh /usr/sbin/postinstall -s /var/cache/sysupgrade/etc.tar.xz -d / fix defaults makedev mtree opensslcertsrehash periodic ptyfsoldnodes rc
    Note that this may overwrite local changes.
    sysupgrade: E: Some postinstall(8) checks have failed
    linveo# 
    

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    Here is what happened when the fix ran:

    linveo# date
    Sat Oct  5 01:02:03 UTC 2024
    linveo# sh /usr/sbin/postinstall -s /var/cache/sysupgrade/etc.tar.xz -d / fix defaults makedev mtree opensslcertsrehash periodic ptyfsoldnodes rc
    Note: Creating temporary directory /tmp/_postinstall.25531.0/etc.tgz
    Note: Extracting files from /var/cache/sysupgrade/etc.tar.xz
    Source directory: /tmp/_postinstall.25531.0/etc.tgz
     (extracted from: /var/cache/sysupgrade/etc.tar.xz)
    Target directory: /
    defaults fix:
            (Checking for pf.boot.conf from /tmp/_postinstall.25531.0/etc.tgz/etc/defaults instead of /tmp/_postinstall.25531.0/etc.tgz/usr.sbin/pf/etc/defaults)
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/defaults/npf.boot.conf to /etc/defaults/npf.boot.conf
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/defaults/rc.conf to /etc/defaults/rc.conf
    makedev fix:
            (Checking for MAKEDEV from /tmp/_postinstall.25531.0/etc.tgz/dev instead of /tmp/_postinstall.25531.0)
            Copied /tmp/_postinstall.25531.0/etc.tgz/dev/MAKEDEV to /dev/MAKEDEV
            (Checking for MAKEDEV.local from /tmp/_postinstall.25531.0/etc.tgz/dev instead of /tmp/_postinstall.25531.0/etc.tgz/etc)
    mtree fix:
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/mtree/special to /etc/mtree/special
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/mtree/NetBSD.dist to /etc/mtree/NetBSD.dist
    opensslcertsrehash fix:
    periodic fix:
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/security to /etc/security
    ptyfsoldnodes fix:
    [1]   Bad system call (core dumped) ${HOST_SH} "${MAKEDEV_DIR}/MAKEDEV" -s pty0 2>... |
          Done                    ${AWK} "\
                BEGIN { before_re = \".*device=...
            Cannot find device major numbers for pty master and slave
    rc fix:
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/bluetooth to /etc/rc.d/bluetooth
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/certctl_init to /etc/rc.d/certctl_init
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/ip6addrctl to /etc/rc.d/ip6addrctl
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/ipfs to /etc/rc.d/ipfs
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/iscsid_volumes to /etc/rc.d/iscsid_volumes
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/named to /etc/rc.d/named
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/npf to /etc/rc.d/npf
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/postfix to /etc/rc.d/postfix
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/resize_root to /etc/rc.d/resize_root
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/securelevel to /etc/rc.d/securelevel
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/sshd to /etc/rc.d/sshd
            Copied /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d/sysdb to /etc/rc.d/sysdb
            (Checking for blocklistd from /tmp/_postinstall.25531.0/etc.tgz/etc/rc.d instead of /tmp/_postinstall.25531.0/etc.tgz/external/bsd/blocklist/etc/rc.d)
    postinstall fixes passed: defaults makedev mtree opensslcertsrehash periodic rc
    postinstall fixes failed: ptyfsoldnodes
    linveo# 
    

    I see another core dump and a post install fix that failed.

    So, what now?

    Also, is the system going to be able to reboot?

    . . . Haha! :) :star: <3

    I hope everyone gets the servers they want!

  • It'd be handy/useful to others if you wrapped those outputs in spoiler tags. ;)

    Thanked by (1)Not_Oles

    It wisnae me! A big boy done it and ran away.
    NVMe2G for life! until death (the end is nigh)

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    Thanks for asking for spoiler tags! I had been thinking about doing that! It is a lot of output. :)

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @AlwaysSkint You said "wrap."

    • Does every line need to start with ">!", or
    • is it enough to have the first and last lines start with ">!", or
    • maybe have ">!" above and below the first and last lines of terminal output, or
    • above and below the code fences "~~~" which are above and below the first and last lines of the terminal output snippet?

    Thanks!

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer
    edited October 5

    Seems to reboot okay!

    linveo# date; reboot
    Sat Oct  5 02:54:22 UTC 2024
    Connection to xxx.xxx.xxx.xxx closed by remote host.
    Connection to xxx.xxx.xxx.xxx closed.
    chronos@penguin:~/servers/linveo$ sleep 60
    chronos@penguin:~/servers/linveo$ `head -n 1 login` 
    Last login: Fri Oct  4 23:55:24 2024 from xxx.xxx.xxx.xxx
    NetBSD 10.99.12 (GENERIC) #0: Wed Oct  2 21:21:26 UTC 2024
    
    Welcome to NetBSD!
    
    We recommend that you create a non-root account and use su(1) for root access.
    linveo# date
    Sat Oct  5 02:55:46 UTC 2024
    linveo# uname -a
    NetBSD linveo.metalvps.com 10.99.12 NetBSD 10.99.12 (GENERIC) #0: Wed Oct  2 21:21:26 UTC 2024 [email protected]:/usr/src/sys/arch/amd64/compile/GENERIC amd64
    linveo#
    

    I hope everyone gets the servers they want!

  • Not_OlesNot_Oles Hosting ProviderContent Writer

    Rerunning the command which produced the ptyfsoldnodes failure seems to succeed after the reboot.

    linveo# sh /usr/sbin/postinstall -s /var/cache/sysupgrade/etc.tar.xz -d / fix defaults makedev mtree opensslcertsrehash periodic ptyfsoldnodes rc
    Note: Creating temporary directory /tmp/_postinstall.1137.0/etc.tgz
    Note: Extracting files from /var/cache/sysupgrade/etc.tar.xz
    Source directory: /tmp/_postinstall.1137.0/etc.tgz
    (extracted from: /var/cache/sysupgrade/etc.tar.xz)
    Target directory: /
    defaults fix:
           (Checking for pf.boot.conf from /tmp/_postinstall.1137.0/etc.tgz/etc/defaults instead of /tmp/_postinstall.1137.0/etc.tgz/usr.sbin/pf/etc/defaults)
    makedev fix:
           (Checking for MAKEDEV from /tmp/_postinstall.1137.0/etc.tgz/dev instead of /tmp/_postinstall.1137.0)
           (Checking for MAKEDEV.local from /tmp/_postinstall.1137.0/etc.tgz/dev instead of /tmp/_postinstall.1137.0/etc.tgz/etc)
    mtree fix:
    opensslcertsrehash fix:
    periodic fix:
    ptyfsoldnodes fix:
    rc fix:
           (Checking for blocklistd from /tmp/_postinstall.1137.0/etc.tgz/etc/rc.d instead of /tmp/_postinstall.1137.0/etc.tgz/external/bsd/blocklist/etc/rc.d)
    postinstall fixes passed: defaults makedev mtree opensslcertsrehash periodic ptyfsoldnodes rc
    postinstall fixes failed:
    linveo# echo $?
    linveo# 0
    

    I hope everyone gets the servers they want!

  • @Not_Oles said: "[1] Bad system call (core dumped) /usr/sbin/etcupdate -a -l ${sflags}"

    Ahh, yes...

    Guess upgrading the kernel first, rebooting and then updating userland would have been the safer option :o

    So maybe: sysupgrade fetch, sysupgrade kernel, reboot, sysupgrade auto

  • @Not_Oles said: You said "wrap."

    In the context of; paste in your content with it all highlighted, then select Spolier.
    You've sussed it though. :)

    Thanked by (1)Not_Oles

    It wisnae me! A big boy done it and ran away.
    NVMe2G for life! until death (the end is nigh)

  • linveolinveo Hosting ProviderOG

    @cmeerw said:
    I have created a new NetBSD 10.0 image with these changes:

    • certificates are now set up correctly out of the box (thanks @Not_Oles for pointing that out)
    • use "log" option on the root filesystem
    • pre-install "modules" and "rescue" packages
    • set savecore=NO in rc.conf and fetch_pkg_vulnerabilities="YES" in daily.conf

    @linveo could you update to the new image please? Hopefully, this should be fairly stable now.

    (Note: the image is AMD only - although I could use a patched kernel, I think it's better to stick with official kernels to avoid having the VM break when updating the kernel)

    Thanks for making these updates. This new template is now available. I appreciate all the work you've done to further the usage of NetBSD!

    Thanked by (1)Not_Oles

    linveo.com | Shared Hosting | KVM VPS | Dedicated Servers

  • @linveo said: Thanks for making these updates. This new template is now available. I appreciate all the work you've done to further the usage of NetBSD!

    It still seems to be rebuilding from the old image (for me on kvmtx12). I can see that you have downloaded the updated image (netbsd-10.0-v3.qcow2).

    Thanked by (1)Not_Oles
  • linveolinveo Hosting ProviderOG

    @cmeerw said:

    @linveo said: Thanks for making these updates. This new template is now available. I appreciate all the work you've done to further the usage of NetBSD!

    It still seems to be rebuilding from the old image (for me on kvmtx12). I can see that you have downloaded the updated image (netbsd-10.0-v3.qcow2).

    I have removed the old template from that node. If you try again it should pull in the latest version. I thought by changing the version number, VF would grab a new version to cache, but I guess not.

    Thanked by (1)Not_Oles

    linveo.com | Shared Hosting | KVM VPS | Dedicated Servers

  • @linveo said:

    @cmeerw said:

    @linveo said: Thanks for making these updates. This new template is now available. I appreciate all the work you've done to further the usage of NetBSD!

    It still seems to be rebuilding from the old image (for me on kvmtx12). I can see that you have downloaded the updated image (netbsd-10.0-v3.qcow2).

    I have removed the old template from that node. If you try again it should pull in the latest version. I thought by changing the version number, VF would grab a new version to cache, but I guess not.

    Thanks, it did install with the new image now.

    Thanked by (1)Not_Oles
  • Not_OlesNot_Oles Hosting ProviderContent Writer

    @AlwaysSkint said: paste in your content with it all highlighted

    Haha! I didn't get that far. I was thinking of putting the about-to-be-posted content into a file and running something like sed -i 's/^/>! /g' file and then copy/pasting the result. Your suggestion is a lot easier! So, thanks for your kind help!

    Thanked by (1)AlwaysSkint

    I hope everyone gets the servers they want!

  • @Crab said: I went through all FreeBSD templates on my Intel instance and they all got installed and worked fine.

    BTW, did you check IPv6 setup? Had another quick look into FreeBSD land, and I don't think IPv6 was set up for me there.

    Thanked by (1)Not_Oles
  • Not_OlesNot_Oles Hosting ProviderContent Writer

    Next up for me might be reading about how to compile all of NetBSD from source, getting the sources (probably with CVS) and trying the compile. I am thinking of trying with my present install based on @cmeerw's previous image. I think it's been . . . like ~30 years . . . since the last time I tried this!

    I hope everyone gets the servers they want!

Sign In or Register to comment.